Перейти к содержимому


Фотография

При старте станка вылетает сработка концевых датчиков

концевой датчик Электропомехи

  • Закрытая тема Тема закрыта
Сообщений в теме: 17

#1 OFFLINE   SashaPizuk

SashaPizuk

    Студент

  • Пользователи+
  • PipPip
  • 31 сообщений
  • Пол:Мужчина
  • Из:Светловодск

Отправлено 04 Июль 2019 - 20:54

Добрый день, уважаемые специалисты и энтузиасты оборудования с чпу. Вопрос такой: китайский станок под управлением ncstudio при нажатии старта программы вылетает с ошибкой, шпиндель только начинает вращаться и сразу ошибка. Программа запускается раза с пятого шестого.На вкладке iostate промаргивает сработка концевика по z. Я его физически отключаю-сработка по х и так до тех пор, пока все концевики не отключишь физически. Станок оборудован реле, которое переключает концевики и драйвер на поворотную ось.(у поворотки свой драйвер). При переключении на обычную работу ошибка возникает примерно раз из десяти стартов, при работе поворотной оси-постоянно. Когда уже запустился, то работает как ни в чем не бывало! Бывает при перемещении портала с клавиатуры он резко тлрмозится с ударом и ошибка! Если у кого-то есть соображения-прошу написать, он уже меня измучил. Завтра попробую пк с дому подключить, буду пытаться локализировть проблему.
Из дому попытаюсь выложить фото.


  • 0

#2 OFFLINE   vv92

vv92

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 8 177 сообщений
  • Пол:Мужчина
  • Город:Н.Новгород
  • Из:Н.Новгород

Отправлено 04 Июль 2019 - 21:05

Попробуйте отсоединить провода концевиков на самой плате.


  • 0
Знаю технику безопасности как свои три пальца.Эксперт - это существо, которое перестало мыслить, ибо оно знает!В мире еще много граблей, на которые не ступала нога человека.
Пожалуйста! Исправляйте мои глупые ошибки (но оставьте мои умные ошибки)!

#3 OFFLINE   SashaPizuk

SashaPizuk

    Студент

  • Пользователи+
  • PipPip
  • 31 сообщений
  • Пол:Мужчина
  • Из:Светловодск

Отправлено 04 Июль 2019 - 21:23

Если я отсоединю провода провода на плате, то датчики отключатся и ошибок не будет. После трансформатора должны быть выравнивающие конденсаторы? Мне кажется, что в момент старта шпинделя (3,2квт) идет просадка напруги и датчики дурееют.
Завтра буду мультиметром звонить все цепи датчиков, может чего прояснится. Датчики все на металл поднесенный реагируют, диод загорается.

Сообщение отредактировал SashaPizuk: 04 Июль 2019 - 21:25

  • 0

#4 OFFLINE   vv92

vv92

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 8 177 сообщений
  • Пол:Мужчина
  • Город:Н.Новгород
  • Из:Н.Новгород

Отправлено 04 Июль 2019 - 21:27

Если провода не коротят, то это наводки на не экранированные провода.

Лечится заменой и заземлением и фильтр из ферритового кольца на провод (желательно экранированный от инвертора к шпинделю.


  • 0
Знаю технику безопасности как свои три пальца.Эксперт - это существо, которое перестало мыслить, ибо оно знает!В мире еще много граблей, на которые не ступала нога человека.
Пожалуйста! Исправляйте мои глупые ошибки (но оставьте мои умные ошибки)!

#5 OFFLINE   SashaPizuk

SashaPizuk

    Студент

  • Пользователи+
  • PipPip
  • 31 сообщений
  • Пол:Мужчина
  • Из:Светловодск

Отправлено 04 Июль 2019 - 22:06

Я тоже думал о наводках, но меня смущает тот факт, что при нормальном режиме таких ошибок менее 10 процентов, а при включении поворотной оси - постоянно. И еще, старт с ошибкой выглядит так: нажал старт, шпиндель немного раскрутился, нажал старт-он еще немного разогнался, и так после третьего-четвертого раза он таки включается.
  • 0

#6 OFFLINE   lkbyysq

lkbyysq

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 6 827 сообщений
  • Пол:Мужчина
  • Город:Санкт-Петербург
  • Из:Санкт-Петербург

Отправлено 04 Июль 2019 - 22:17

при нормальном режиме таких ошибок менее 10 процентов, а при включении поворотной оси - постоянно.

 

В любом режиме ошибок должно быть всегда НОЛЬ.


  • 1
Станислав Ерофеев
Beaver 9A, Beaver 9AT2, KingCut X6, WoodPecker 1224, Roland EGX-300, Roland EGX-20, ZeldeR 0613TP.

#7 OFFLINE   SashaPizuk

SashaPizuk

    Студент

  • Пользователи+
  • PipPip
  • 31 сообщений
  • Пол:Мужчина
  • Из:Светловодск

Отправлено 05 Июль 2019 - 01:27

Это ясно, что мне делать - непонятно.
  • 0

#8 OFFLINE   lkbyysq

lkbyysq

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 6 827 сообщений
  • Пол:Мужчина
  • Город:Санкт-Петербург
  • Из:Санкт-Петербург

Отправлено 05 Июль 2019 - 01:31

Что делать? Не смущаться.
  • 0
Станислав Ерофеев
Beaver 9A, Beaver 9AT2, KingCut X6, WoodPecker 1224, Roland EGX-300, Roland EGX-20, ZeldeR 0613TP.

#9 OFFLINE   Admin

Admin

    "Добрый" Админ

  • Главные администраторы
  • PipPipPipPipPipPipPipPipPipPip
  • 1 531 сообщений
  • Пол:Мужчина
  • Из:Мир-CNC

Отправлено 05 Июль 2019 - 07:11

Ложное срабатывание концевиков при запуске шпинделя
Станок клинит, срабатывает концевик и выдает ошибки



#10 OFFLINE   SashaPizuk

SashaPizuk

    Студент

  • Пользователи+
  • PipPip
  • 31 сообщений
  • Пол:Мужчина
  • Из:Светловодск

Отправлено 05 Июль 2019 - 13:24

Добрый день, один из проводов концевика звонится на корпус станка. Так не должно быть?
  • 0

#11 OFFLINE   lkbyysq

lkbyysq

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 6 827 сообщений
  • Пол:Мужчина
  • Город:Санкт-Петербург
  • Из:Санкт-Петербург

Отправлено 05 Июль 2019 - 15:21

Добрый день, один из проводов концевика звонится на корпус станка. Так не должно быть?

Такое имеет право быть.
  • 0
Станислав Ерофеев
Beaver 9A, Beaver 9AT2, KingCut X6, WoodPecker 1224, Roland EGX-300, Roland EGX-20, ZeldeR 0613TP.

#12 OFFLINE   SashaPizuk

SashaPizuk

    Студент

  • Пользователи+
  • PipPip
  • 31 сообщений
  • Пол:Мужчина
  • Из:Светловодск

Отправлено 05 Июль 2019 - 15:47

В шкафу есть плата, к которой приходит кабель с пк, к ней приходят все концевики, провода с инвертера. Один провод из нее прикручен к шкафу в котором все смонтировано, шкаф заземлен. После долгих поисков обнаружил, что если убрать этот провод с массы то все ошибки пропадают, работает отлично. Чем чревато его отключение? Что-то может сгореть?
У меня с телефона не получается добавить фото.
Вот эта плата.

Прикрепленные изображения

  • IMG_20190705_124532.jpg

  • 0

#13 OFFLINE   lkbyysq

lkbyysq

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 6 827 сообщений
  • Пол:Мужчина
  • Город:Санкт-Петербург
  • Из:Санкт-Петербург

Отправлено 05 Июль 2019 - 15:54

Чем чревато его отключение?

 

Может не работать "таблетка" обнуления поверхности по Z.


  • 0
Станислав Ерофеев
Beaver 9A, Beaver 9AT2, KingCut X6, WoodPecker 1224, Roland EGX-300, Roland EGX-20, ZeldeR 0613TP.

#14 OFFLINE   SashaPizuk

SashaPizuk

    Студент

  • Пользователи+
  • PipPip
  • 31 сообщений
  • Пол:Мужчина
  • Из:Светловодск

Отправлено 05 Июль 2019 - 15:55

Перепробывал все, все работает.
  • 0

#15 OFFLINE   lkbyysq

lkbyysq

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 6 827 сообщений
  • Пол:Мужчина
  • Город:Санкт-Петербург
  • Из:Санкт-Петербург

Отправлено 05 Июль 2019 - 16:00

В шкафу есть плата, к которой приходит кабель с пк, к ней приходят все концевики, провода с инвертера. Один провод из нее прикручен к шкафу в котором все смонтировано, шкаф заземлен. После долгих поисков обнаружил, что если убрать этот провод с массы то все ошибки пропадают, работает отлично

 

 

Перепробывал все, все работает.

 

Это не правильное заземление.

Может было. Может и осталось.

Никакие комментарии не будут корректны, пока не нарисуете электрическую и монтажную схему реальных соединений.


  • 0
Станислав Ерофеев
Beaver 9A, Beaver 9AT2, KingCut X6, WoodPecker 1224, Roland EGX-300, Roland EGX-20, ZeldeR 0613TP.

#16 OFFLINE   SashaPizuk

SashaPizuk

    Студент

  • Пользователи+
  • PipPip
  • 31 сообщений
  • Пол:Мужчина
  • Из:Светловодск

Отправлено 05 Июль 2019 - 18:49

В общем ситуация с этим проводом такая: мультиметром он звонится и на корпус шкафа и на заземление, но пока я его не прикручиваю к шкафу станок работает отлично, как только прикручу-ошибки начинаются. Пока оставил неприкрученным, понаблюдаю.
Спасибо всем за советы и ссылки где почитать.
По поводу схемы там вообще все плохо, ее походу не существует! Гарантия закончилась, производитель не хочет им заниматься, сам ковыряю.
Вот такое ферритовое кольцо решило все проблемы, провод прикрутил на место!

Прикрепленные изображения

  • IMG_20190705_154735.jpg

  • 0

#17 OFFLINE   lkbyysq

lkbyysq

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 6 827 сообщений
  • Пол:Мужчина
  • Город:Санкт-Петербург
  • Из:Санкт-Петербург

Отправлено 05 Июль 2019 - 18:57

Красивое кольцо.

 

 

Добрый день, уважаемые специалисты и энтузиасты оборудования с чпу. Вопрос такой: китайский станок под управлением ncstudio при нажатии старта программы вылетает с ошибкой, шпиндель только начинает вращаться и сразу ошибка. Программа запускается раза с пятого шестого.На вкладке iostate промаргивает сработка концевика по z. Я его физически отключаю-сработка по х и так до тех пор, пока все концевики не отключишь физически. Станок оборудован реле, которое переключает концевики и драйвер на поворотную ось.(у поворотки свой драйвер). При переключении на обычную работу ошибка возникает примерно раз из десяти стартов, при работе поворотной оси-постоянно. Когда уже запустился, то работает как ни в чем не бывало! Бывает при перемещении портала с клавиатуры он резко тлрмозится с ударом и ошибка! Если у кого-то есть соображения-прошу написать, он уже меня измучил. 

 

Пропустите сквозь ферритовое кольцо серый провод!


Сообщение отредактировал lkbyysq: 05 Июль 2019 - 18:58

  • 0
Станислав Ерофеев
Beaver 9A, Beaver 9AT2, KingCut X6, WoodPecker 1224, Roland EGX-300, Roland EGX-20, ZeldeR 0613TP.

#18 OFFLINE   SashaPizuk

SashaPizuk

    Студент

  • Пользователи+
  • PipPip
  • 31 сообщений
  • Пол:Мужчина
  • Из:Светловодск

Отправлено 05 Июль 2019 - 22:57

Всем помогавшим большое спасибо, тему можно закрывать!
  • 0





Темы с аналогичным тегами концевой датчик, Электропомехи

Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 анонимных