Перейти к содержимому


Фотография

Настройка MACH3

Настройка Mach3

  • Авторизуйтесь для ответа в теме
Сообщений в теме: 25

#1 OFFLINE   FinRus

FinRus

    Абитуриент

  • Пользователи
  • Pip
  • 5 сообщений
  • Из:Moscow

Отправлено 22 Июль 2011 - 13:11

Приобрел для себя станок из китая . Вот такой
Пробую настроить MACH3. Установил чистую WinXP на компьютер. Подключил все кабели. Скачал с официального сайта демо версию MACH3 (ограничение только по количеству команд). Настроил порты как в мануале. Итог при управлении в MACH направляющая Y двигается только в одном направлении независимо от нажатия клавиш управления. X и Z ведут себя аналогично. При этом может двигаться по оси. А через минуту как не нажимай молчит ни шума двигателя ни малейшего признака движения. Через некоторое время опять можно двигать, но в одном направлении. Если вводить команды например G0 Y100 двигает доходит до 100 и останавливается. Если ввести G0 Y-100 опять двигает но вновь в том же направлении. Попробую приложить настройки.Но пока даже незнаю где копать. Может железо? Прошу помощи.
 

Похожие темы:
Настройка Mach3 для 3 осей
Настройка Motor Tuning

 


  • 0

#2 OFFLINE   Lodochnik

Lodochnik

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 2 511 сообщений
  • Пол:Мужчина
  • Из:Королев

Отправлено 22 Июль 2011 - 14:14

Надо смотреть ,что за контроллер,драйвера,как подключали и т.п. Если до г.Королева Вам не далеко,приезжайте,помогу чем смогу.
  • 0
С уважением, Олег.

#3 OFFLINE   FinRus

FinRus

    Абитуриент

  • Пользователи
  • Pip
  • 5 сообщений
  • Из:Moscow

Отправлено 22 Июль 2011 - 14:52

Прилагаю настройки. До Королева недалеко и наверное подъеду. А куда в Королев?

Прикрепленные изображения

  • 364653841.jpg
  • 364653868.jpg
  • 364653880.jpg
  • 364653890.jpg
  • 364653897.jpg
  • 364653900.jpg

  • 0

#4 OFFLINE   САНЕК

САНЕК

    Бакалавр CNC

  • Пользователи+
  • PipPipPip
  • 123 сообщений
  • Пол:Мужчина
  • Из:Н.Новгород

Отправлено 22 Июль 2011 - 15:08

скорее всего вам надо настроить выходы step и dir.rrrrrrrrrr.JPG
  • 0

#5 OFFLINE   FinRus

FinRus

    Абитуриент

  • Пользователи
  • Pip
  • 5 сообщений
  • Из:Moscow

Отправлено 22 Июль 2011 - 16:18

Вот при такой установке ось Z работает идеально. Но стоит только активировать любую из осей X или Y и все Z либо вообще не работает либо только в одном направлении.

Включил все оси. Z работала отлично. Оси X и Y перемещались только в одном направлении. Потом перестало вообще все двигаться. Ничего не менял. Z перестала работать. потом стала работать только в одном направлении Y только в одном. X перестала работать. Никаких настроек вообще не менял. Потом опять все перестало двигаться. После нескольких нажатий на клавиши оси Z двинулась вверх.Остальные двигатели молчат. Хотя буквально 5 минут назад двигались хоть и в одном направлении.

Включил все оси. Z работала отлично. Оси X и Y перемещались только в одном направлении. Потом перестало вообще все двигаться. Ничего не менял. Z перестала работать. потом стала работать только в одном направлении Y только в одном. X перестала работать. Никаких настроек вообще не менял. Потом опять все перестало двигаться. После нескольких нажатий на клавиши оси Z двинулась вверх.Остальные двигатели молчат. Хотя буквально 5 минут назад двигались хоть и в одном направлении.

Прикрепленные изображения

  • 364657923.jpg

  • 0

#6 OFFLINE   FinRus

FinRus

    Абитуриент

  • Пользователи
  • Pip
  • 5 сообщений
  • Из:Moscow

Отправлено 22 Июль 2011 - 17:45

Подключил кабель управления к ноутбуку Sony старенькому с док станцией и LPT портом. И все заработало в прежних настройках.Правда иногда все равно бывают пропуски шагов, склоняюсь что все таки ноутбучный LPT не очень приспособлен для работы со станками. По всей вероятности плохо работает порт компьютера (стационарного) или с кабелем. Склоняюсь больше к порту. Возникает вопрос как настроить LPT порт компьютера? Или просто купить дополнительно плату с LPT портом. Встроенный выключить и запустить дополнительный. И какую лучше платку купить с портом?
  • 0

#7 OFFLINE   Lodochnik

Lodochnik

    Гуру CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 2 511 сообщений
  • Пол:Мужчина
  • Из:Королев

Отправлено 22 Июль 2011 - 18:22

По всей видимости уровни порта не соответствуют Вашему контроллеру,возможно порт просто не тянет контроллер по току.Не спешите плату с портом покупать,покупка может не исправить ситуацию.
По поводу встречи- в личку.
  • 0
С уважением, Олег.

#8 OFFLINE   FinRus

FinRus

    Абитуриент

  • Пользователи
  • Pip
  • 5 сообщений
  • Из:Moscow

Отправлено 22 Июль 2011 - 20:18

Болван оказался я. В комплекте к контроллеру шел кабель с разъемом USB на одном конце, а на другом разъем питания. Я не понимал зачем он и не подключал к контроллеру. Тут решил подключить и сразу все заработало в штатном режиме. Видимо это доп питание по 5 вольтам.Век живи век учись. Спасибо всем за помощь!!!
  • 0

#9 OFFLINE   Pontiak

Pontiak

    Абитуриент

  • Пользователи
  • Pip
  • 2 сообщений
  • Из:Москва

Отправлено 20 Март 2012 - 00:27

ребята помогите настроить станок CNC ingi800 работает с mach3, ни как немогу правильно настроить сбивается вовремя работы, проверял люфтов нет, помогите настроить.
  • 0

#10 OFFLINE   valery_k

valery_k

    Доктор CNC

  • Опытный
  • PipPipPipPipPip
  • 599 сообщений
  • Пол:Мужчина
  • Из:СПб.

Отправлено 20 Март 2012 - 00:41

Что случилась то?
Толком объясни, как сбывается такой красавец?
  • 0

#11 OFFLINE   Pontiak

Pontiak

    Абитуриент

  • Пользователи
  • Pip
  • 2 сообщений
  • Из:Москва

Отправлено 20 Март 2012 - 11:53

загружается фаел начинает работат где то после 10000 шагов начинает сбыватся каждым шагом 0.2 мм по всем осям в итоге получается искажонный модель ,мне кажется что в motor nuning забиты не правилные цыфры, и еше в каких то разделох надо настроит, а где и какие настройки я не знаю помогите.
  • 0

#12 OFFLINE   valery_k

valery_k

    Доктор CNC

  • Опытный
  • PipPipPipPipPip
  • 599 сообщений
  • Пол:Мужчина
  • Из:СПб.

Отправлено 20 Март 2012 - 13:03

В Mashe настройки жесткие, маsh не может менять настройки в процессе обработки детали.
В демо версии Mash есть ограничение по количеству строк кода.
У вас стоит неограниченная версия?
Покажите изделие.
  • 0

#13 OFFLINE   Werewolf

Werewolf

    Абитуриент

  • Пользователи
  • Pip
  • 5 сообщений
  • Пол:Мужчина
  • Из:Павлодар

Отправлено 22 Декабрь 2016 - 18:00

Здравствуйте уважаемые знатоки! Помогите с настройкой фрезерного станка CNC 3040. Итак проделанная работа: 
1) Windows 7, чистая, оптимизированная
2) Драйвера Mach3 встали успешно
3) В настройках mach3  сомневаюсь в правильности выставленных портов и пинов. Сегодня все оси работали, ездили туда сюда, но недолго: пару минут. потом не реагируют. через некоторое время едут но с торможением и зависанием, бывает даже что только в одну сторону. Решил что дело в настройках мотор тюнинга, там вообще разобраться не могу...как высчитать шаг, скорость, ускорение и последние две циферки. Вместе со станком была инструкция на 3020 (продавец сказал что настройки одинаковы), также скачал в нете инструкцию на эту модель и настройки там совершенно другие. На Вашем сайте третьи ))). Помогите, а то работа встала вся ((( заказы принимаем, а сделать пока что ничего не можем (((


  • 0

#14 OFFLINE   preps

preps

    Пианист CNC

  • Cтарожил
  • PipPipPipPipPipPipPipPipPipPip
  • 4 639 сообщений
  • Пол:Мужчина
  • Город:Mos Angeles, Butovo
  • Интересы:Здесь могла бы быть ваша реклама...
  • Из:Москва

Отправлено 22 Декабрь 2016 - 18:19

http://mir-cnc.ru/fo...просы-по-mach3/


  • 0

#15 OFFLINE   Werewolf

Werewolf

    Абитуриент

  • Пользователи
  • Pip
  • 5 сообщений
  • Пол:Мужчина
  • Из:Павлодар

Отправлено 22 Декабрь 2016 - 18:34

Всё перерыл, все форумы, весь инет. Все равно допереть не могу...


  • 0

#16 OFFLINE   mihams

mihams

    Магистр CNC

  • Пользователи+
  • PipPipPipPip
  • 488 сообщений
  • Из:Kovrov

Отправлено 22 Декабрь 2016 - 19:55

Здравствуйте уважаемые знатоки! Помогите с настройкой данного китайского фрезерного станка. Итак проделанная работа: 

1) Windows 7, чистая, оптимизированная

2) Драйвера Mach3 встали успешно

3) В настройках mach3  сомневаюсь в правильности выставленных портов и пинов. Сегодня все оси работали, ездили туда сюда, но недолго: пару минут. потом не реагируют. через некоторое время едут но с торможением и зависанием, бывает даже что только в одну сторону. Решил что дело в настройках мотор тюнинга, там вообще разобраться не могу...как высчитать шаг, скорость, ускорение и последние две циферки. Вместе со станком была инструкция на 3020 (продавец сказал что настройки одинаковы), также скачал в нете инструкцию на эту модель и настройки там совершенно другие. На Вашем сайте третьи ))). 

 

если все оси работали - значит подключено правильно

скорост и ускорения ставят в зависимости от мощности моторов. начинайте с малых значений, потом добавите при необходимости (1000 и 100)

последние циферки поставте - 5

импульс шаг если рассчитать не можете - подберите

двигайте оси на какое либо расстояние и меряйте сколько он точно проехал

проехал меньше - увеличивайте значение

проехал больше - уменьшайте значение

начинать хоть с единицы можно))))

 

забыл добавить... по ходу на каком то усб-контроллере сделано? они сами по себе работают с задержками(если в ручном режиме двигать)


  • 0

#17 OFFLINE   Werewolf

Werewolf

    Абитуриент

  • Пользователи
  • Pip
  • 5 сообщений
  • Пол:Мужчина
  • Из:Павлодар

Отправлено 22 Декабрь 2016 - 20:22

контроллер ЛПТ на ЛПТ...а в общем за подсказочки огромное спасибо!!!


  • 0

#18 OFFLINE   Werewolf

Werewolf

    Абитуриент

  • Пользователи
  • Pip
  • 5 сообщений
  • Пол:Мужчина
  • Из:Павлодар

Отправлено 23 Декабрь 2016 - 12:20

Что-то я опять мучаюсь и такая же фигня вылазиет...2 минуты утром поработали оси нормально, поездили, а потом встали...то только в одном направлении едут, то вообще не едут, как ни меняю шаг и скорости мотора все равно не хочет ползти...в чем фишка может быть?


  • 0

#19 OFFLINE   mihams

mihams

    Магистр CNC

  • Пользователи+
  • PipPipPipPip
  • 488 сообщений
  • Из:Kovrov

Отправлено 23 Декабрь 2016 - 12:27

Что-то я опять мучаюсь и такая же фигня вылазиет...2 минуты утром поработали оси нормально, поездили, а потом встали...то только в одном направлении едут, то вообще не едут, как ни меняю шаг и скорости мотора все равно не хочет ползти...в чем фишка может быть?

 

да в чем угодно... комп, соединения, концевики, выход за софтлимиты, косячный Мач, глюк драйверов, перкосы в механике.... не весь список)))


  • 0

#20 OFFLINE   Admin

Admin

    "Добрый" Админ

  • Главные администраторы
  • PipPipPipPipPipPipPipPipPipPip
  • 1 347 сообщений
  • Пол:Мужчина
  • Из:г.Новосибирск

Отправлено 23 Декабрь 2016 - 12:36

в чем фишка может быть?

перемещается не в ту сторону







Темы с аналогичным тегами Настройка Mach3

Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных