Перейти к содержимому


Фотография

Плавает значение обратной связи от сервопака

сервопривод

  • Авторизуйтесь для ответа в теме
В теме одно сообщение

#1 OFFLINE   mihams

mihams

    Гуру CNC

  • Пользователи+
  • PipPipPipPipPipPipPipPipPipPip
  • 1 108 сообщений
  • Из:Kovrov

Отправлено 27 Ноябрь 2017 - 18:34

Не могу понять в какой момент он импульсы теряет.
чем больше в уп смены направления, тем больший разбег получается.
может в + может в - уйти
интерфейс АВ, как у энкодера
ускорения, скорость на углу и скорость на радиус уменьшил - разбег стал минимальным... но все равно плывет, как будь то не успевает в заданное положение вставать.
 
но если в положение не встал и не досчитал в плюс, то он и в минус такое же количество импульсов не должен выдавать... 
сумма импульсов в плюс и минус данных сервопаку должна быть 0 в начальной точке и сумма отданых сервопаком должна 0 быть... но оно не так)
или я что то недопонимаю?
 
физически в 0, по импульсам управления в 0, по показаниям обратной связи уплыл на миллиметр за полчаса в любую сторону.
по всем осям так.
редукцию пробовал и на сервопаках и на счпу задавать... ведет себя совершенно одинаково.
количество импульсов прописывал числом и задавал деление от физического энкодера... то же не помогает.
 
провода до сервопака без экрана... но они такие в комплекте с счпу шли... и на других станках то же без экрана стоят
  • 0

#2 OFFLINE   mihams

mihams

    Гуру CNC

  • Пользователи+
  • PipPipPipPipPipPipPipPipPipPip
  • 1 108 сообщений
  • Из:Kovrov

Отправлено 28 Ноябрь 2017 - 18:44

дело было не в бабине... автонастройку не отключил


  • 0





Темы с аналогичным тегами сервопривод

Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных