
1 Программное обеспечение обрабатывающих центров с ЧПУ

Данное руководство относится к обрабатывающим центрам:

● ROVER
● SKIPPER
● ARROW

!!! Данное руководство содержит только краткую информацию по программному обеспечению 
обрабатывающих  центров.  Для  получения  более  полной  информации  используйте 
документацию  «BiesseWorks  Instructions  for  use»,  «BiesseWorks  Система  программирования 
обработок  Инструкция  по  эксплуатации»  и  Руководство  по  эксплуатации  обрабатывающим 
центром.

Программное обеспечение обрабатывающих центров, указанных выше, включает в себя:

● операционная система – MICROSOFT WINDOWS XP PROFESSIONAL;

● программа управления осями обрабатывающего центра – WRT;

● программный пакет для создания программ обработок – BIESSEWORKS.
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2 WRT

Программный пакет WRT управляет осями обрабатывающего центра.

WRT включает в себя:
● QUOTE - отображает координаты осей, состояние станка, начальную точку детали, тип 

выбранного шпинделя и процентное соотношение скорости движения осей (OVERRIDE).

 
Состояния станка:

Отсутствие ошибки

Наличие ошибки

Обнуление

Движение в ручном режиме

Движение по отметкам

Старт программы

Программа приостановлена

Запрограммированная приостановка

ПЛК отключен.
Сигнализирует также и об отсутствии некоторых 
приложений, необходимых для функционирования 
ЧПУ.
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Обнуление осей:

 → 

Нажмите на PLC клавиши Clear - Stop - Reset → 
→ Включите подачу управляющего напряжения → 
→ Проверьте чтобы в окне Quote было выбрано - Global Homing →
→ Нажмите на PLC клавиши Clear - Stop - Reset — Start →

Обнуление осей необходимо делать после запуска программного обеспечения и при появлении 
сообщения об ошибке с запросом на эту операцию (Axis not callibrated).

Движение осей в ручном режиме:

 →

→ Выберите ось → Нажмите на PLC клавиши управления осями

Выполнения программ в автоматическом режиме:

Режим Automatic должен быть выбран для исполнения программ обработок.

Движение элементов рабочих групп:
Ручное перемещение элементов рабочих групп полезно при смене инструментов и проведении 
технического обслуживания

 →  → Выберите шпиндель →

→ Выполните инструментальное оснащение или техническое обслуживание →
→ Выберите еще раз тот же шпиндель, чтобы вернуть его в начальное состояние
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3 BIESSEWORKS

Программный пакет  BIESSEWORKS состоит из следующих приложений:

● EDITOR - предназначено для создания программ обработок;

● MACHINE CONFIGURATION - предназначено для оснащения рабочих групп;

● TOOL MANAGER - предназначено для работы с базой инструментов;

● WORK TABLE TOOLING - предназначено для оснащения рабочего стола;

● BACKUP MANAGER - предназначено для создания резервных копий элементов 

программы BIESSEWORKS и восстановление данных из резервных копий;

● BATCHRUN - выполнение заказов и преобразование программ обработок в файлы с 

форматом ISO, для последующего их исполнения в программе WRT;

● FINDKILL - предназначено для удаления процессов, созданных программным пакетом 

BIESSEWORKS, в случае необходимости их аварийного завершения.

Функциональные ограничения

В программе могут быть отключены некоторые функции (создание геометрии-текста, симуляция 

программы обработки и другие). Данные ограничения накладываются лицензионным ключом.

Для просмотра списка функциональных возможностей выполните следующие операции:

EDITOR → Main → Settings → User → 

Уровень доступа пользователя

По умолчанию при запуске приложений BIESSEWORKS пользователь получает уровень 

доступа 1. Для того чтобы получить возможность вносить изменения в BIESSEWORKS 

необходимо ввести пароль для получения доступа более высокого уровня. Этот пароль вы 

можете получить у техника.

Для  изменения  уровня  доступа  в  приложениях  EDITOR,  MACHINECONFIGURATION, 

WORKTABLETOOLING выполните следующие операции: 

File → Settings → Password → В поле Password введите выданный вам пароль →

→ Confirm → Ok
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В приложении TOOLMANAGER выполните следующие операции:

Main → Settings → Password → В поле Password введите выданный вам пароль →

→ Confirm → Ok

Работа с базой инструментов

Все инструменты, используемые на обрабатывающем центре должны быть занесены в базу 
инструментов TOOL MANAGER.

Для внесения изменений необходимо иметь уровень доступа выше 1 (смотрите страницу 2).

Для запуска программы TOOLMANAGER выполните следующие операции:
Откройте окно Editor → Tools → Tools...
или
Start → Programms → BiesseWorks → ToolManager.

База инструментов имеет иерархическую структуру. Каждый инструмент принадлежит к 
определенному классу (Class) и типу (Type).

CLASS определяет основную ступень иерархии и определяет выполняемую операцию 
инструментом.

По умолчанию созданы следующие классы:
C_Routing - определяет все фрезы;
C_Cutting - определяет все пилы;
C_Drilling - определяет все сверла;

TYPE (тип) определяет вторую ступень иерархии и различает инструменты внутри группы 
CLASS.
Разделение инструментов по «типу» не является обязательным. Данная ступень иерархии может 
быть полезной при наличии большого количества инструментов. В программе обработке можно 
указать диаметр инструмента и его «тип» (при этом инструмент должен иметь уникальный 
диаметр в данной группе инструментов), а не искать инструмент по имени в большом списке.

Просмотр и изменение параметров инструмента:
Щелкните дважды мышкой по одной из позиций в колонке CODE.

Создание нового инструмента с нуля:
!!! Пользователь должен иметь доступ выше 1-го уровня
Tools → New tool → Введите в открывшемся окне параметры инструмента →  

5



Таблица Описание полей параметров инструмента

Class Укажите класс инструмента (C_Routing, C_Cutting, C_Drilling)

Type Укажите тип инструмента

Code Введите уникальное имя инструмента

Coupling Укажите тип крепления инструмента (ISO, HSK, F10)

Description* Комментарий к инструменту 

 BMP Ассоциация графического изображения с инструментом

 DXF Ассоциация чертежа сечения инструмента в формате DXF

Dir. of rotation Направление вращения: Clockwise (по часовой) или AntiClockwise (против часовой)

Diameter Диаметр инструмента

Thickness (Length)** Толщина пилы (длина фреза или сверла)

Max Diameter Максимальный диаметр инструмента

W.Dimen. Код габарита инструмента: 0 - параметр отключен; 1 – инструмент занимает одну ячейку в 
магазине; 2 — одну ячейку + следующую; 3 — одну ячейку + предыдущую; 4 — одну ячейку + 
предыдущую + следующую

Cutter Length Длина режущей части инструмента

Max Vert step Глубина, достигаемая инструментом во время вертикальной обработки детали 

Deflector Код отражателя стружки

Floating Отметить, если присутствует копир

Blower Отметить, если присутствует обдув

Presser Отметить, если присутствует дополнительный прижим

Enable class 
management

Отметить, если необходимо использовать параметры скорости в соответствии с параметрами 
связанными с классом указанным выше

Std WkSpd Стандартная скорость подачи инструмента

Std RotSpd Стандартная скорость вращения инструмента
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Std LwrSpd Стандартная скорость опускания инструмента

Max WkSpd Максимальная скорость подачи инструмента

Max RotSpd Максимальная скорость вращения инструмента

Max LwrSpd Максимальная скорость опускания инструмента

Min WkSpd Минимальная скорость подачи инструмента

Min RotSpd Минимальная скорость вращения инструмента

Min LwrSpd Минимальная скорость опускания инструмента

Dec. Time Время остановки инструмента

Safety Безопасное удаление инструмента от панели

Acc. Time Время разгона инструмента

Corner ang. Угол режущей части инструмента (не используется для сверел)

Uniclamp saf. Безопасное расстояние при использовании uniclamp 
(параметр uniclamp должен быть задан в параметрах заготовки)

Correction Параметр для станка Skipper 

* - Поля необязательные для заполнения
** - Содержимое поля зависит от выбранного класса инструмента

Определение параметра length (длины инструмента):

Определение параметра Safety (безопасного удаления инструмента):

Параметр Safety для сверла определяется по следующей формуле:

Safety = (Длинна самого длинного сверла) «минус» (Длинна данного сверла) «плюс» 

(Расстояние безопасного удаления сверла от обрабатываемой детали (обычно 10 мм))

7



Создание нового инструмента на основе уже существующего:

!!! Пользователь должен иметь доступ выше 1-го уровня 

Щелкните правой кнопкой мышки по позиций в колонке CODE копируемого инструмента 

→ Copy tool → Измените в открывшемся окне параметры инструмента →  

(Описание полей параметров инструмента смотрите на предыдущей странице)

Удаление инструмента из базы:

!!! Пользователь должен иметь доступ выше 1-го уровня

Щелкните правой кнопкой мышки по позиций в колонке CODE удаляемого инструмента 

→ Delete tool →  

Переименование инструмента:

!!! Пользователь должен иметь доступ выше 1-го уровня

Щелкните правой кнопкой мышки по позиций в колонке CODE инструмента → 

→ Rename tool → Введите в открывшемся окне новое имя инструмента →  

! После внесения изменений необходимо выполнить сохранение:

Main → Save tools
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Оснащение рабочих групп

Все инструменты установленные в рабочих группах необходимо указать в программе 
MACHINECONFIGURATION. 

!!! Оснащение рабочих групп указанное в программе  MACHINECONFIGURATION 
должно соответствовать инструментам физически установленным в рабочих группах. 

Для запуска программы MACHINECONFIGURATION выполните следующие операции:
Откройте окно Editor → Tools → MachineConfiguration
или 
Start → Programms → BiesseWorks → MachineConfiguration

Сокращенное обозначение шпинделей:
T# - вертикальный сверлильный шпиндель;
TH# - горизонтальный сверлильный шпиндель;
TP# - электрошпиндель;

# - номер шпинделя.

Выполнение инструментального оснащения рабочих групп:
Tooling → Maching tooling → В левом древовидном списке выберите нужную рабочую 
группу →

удаление инструмента из шпинделя:
В графической области нажмите правой кнопкой мыши на шпинделе →
→ Untool the selected spindles
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вставка инструмента в шпиндель:
В графической области нажмите левой кнопкой мыши на шпинделе →
→  В правом древовидном списке нажмите на инструменте сначала левой кнопкой 
мыши, а затем правой

просмотр информации по инструменту:
Щелкните дважды левой кнопкой мыши
на инструменте в правом древовидном списке

просмотр информации по шпинделю:
Щелкните дважды левой кнопкой мыши
на шпинделе в графической области

Сохранение конфигурации в файл:
 → Введите имя файла и путь для сохранения → Save

Открытие конфигурации из файла:
 → Укажите путь и имя файла → Open

Выполнение инструментального оснащения магазинов инструментов:
Tooling → Magazne tooling → В левом древовидном списке выберите нужный магазин

Внесение изменений осуществляется как и при работе с инструментальным оснащением 
рабочих групп.

Выполнение инструментального оснащения агрегатов:
Tooling → Aggregate tooling → В левом древовидном списке выберите нужный агрегат

Внесение изменений осуществляется как и при работе с инструментальным оснащением 
рабочих групп.

! После внесения изменений необходимо выполнить сохранение:
 → 

Получение дополнительной информации по оснащению станка

Просмотр технических данных шпинделей:
Разместите курсор на графический элемент, в котором находится шпиндель →
→ Щелкните левой кнопкой мыши → 
→ Щелкните дважды левой кнопкой мыши на изображении шпинделя

Просмотр списка всех шпинделей и получение информации о шпинделе:
Database → Spindles → Щелкните дважды левой кнопкой мыши на шпинделя

Просмотр списка магазинов инструментов и получение информации по ним:
Database → Tool magazines → Щелкните дважды левой кнопкой мыши на магазине

Просмотр списка агрегатов и получение информации по ним:
Database → Aggregates → Щелкните дважды левой кнопкой мыши на агрегате
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Создание программ обработок

Программы обработки создаются в приложении EDITOR:

В стойке ЧПУ обрабатывающего центра программа Editor запускается автоматически при 
запуске системы.

Для ручного запуска выполните следующие операции:

Start → Programms → BiesseWorks → Editor

Открытие ранее созданной программы обработки:
File → Open → Укажите имя и путь файла программы обработки → Open

Создание новой программы обработки:
File → New →  Во вкладке Main data page введите параметры заготовки:

LPX – размер по оси X; 

LPY – размер по оси Y; 

LPZ – размер по оси Z 

→ Во вкладке Additional data page введите дополнительные параметры заготовки:
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Origins list Список упоров, в которых необходимо расположить заготовку
Если поле оставить пустым, упор выбирается на стойке ЧПУ

Sole origin Использование одного упора в рабочей области

User data Пользовательские настройки (описание после этой таблицы)

Symmetry Использовать симметричные шпиндели

Measure in inches Размеры в дюймах (по умолчанию в мм)

X cut. position Координата по оси X, перейдя которую программа разделит обработку и введет 
остановку для перемещения заготовки. Используется при обработке больших заготовок.

Jig thickness Толщина контршаблона (подложки)

Keyboard offset Включает использование клавиатуры на станке для смещения начальной точки

Movement in X Смещение начальной точки по оси X при применении упоров с двойным ходом

Movement in Y Смещение начальной точки по оси Y при применении упоров с двойным ходом

Uniclamp Включает использование uniclamp

Collision control Проверка столкновений подвижных частей станка с элементами стола (не работает при 
использовании агрегата 21 и отражателя стружки)

Locking zone ??? Тип независимой зоны блокировки 

Material Текстура поверхности заготовки, отображаемая в режиме симуляции

Пользовательские параметры программы обработки
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Suction cups and clamps  - автоматическая фиксация заготовки вакуумными подушками

 - автоматическая фиксация заготовки с использованием uniclamp

 - блокировка заготовки в ручном режиме

Bars or Idle wheels or Air table Подключает или отключает автоматическое использование реечных 
суппортов, шаровых суппортов или электровентилятора для облегчения 
позиционирования детали на рабочем столе

Supports up at end of locking Упоры остаются поднятыми по окончанию блокировки детали

Pushers Включает или отключает автоматическое применение толкателей 

Export the tool list Созданная программа обработки содержит список инструментов

Export the work table tooling set-up Созданная программа обработки содержит оснащение рабочего стола

Export the symmetrical section Созданная программа обработки содержит данные для выполнения обработки 
на зеркальной начальной точке

→  →  → 

После создания новой программы обработки выводится окно, приведенное на рисунке:
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Текстовое отображение программы обработки
Данная часть окна программы BiesseWorks содержит созданную программу обработки в виде 
кода написанного на языке BiesseWorks.

Примечание 1: Для отображение следующего скрытого параметра нажмите клавиши 

CTRL + SPACEBAR

Примечание 2: Для отображение полного списка скрытых параметров нажмите клавиши

CTRL + SHIFT + SPACEBAR

Стороны и углы детали
Стороны заготовки имеют следующую нумерацию:

У каждой стороны точками отсчета являются углы, которые определяют начало отсчета 
координат обработок
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Пример двух отверстий с одинаковыми координатами, но выполненные от разных углов.

Изменение параметров заготовки:
Program → Peace data

Фрезерование по траектории

Insert → Millings → Basic → Milling → Заполните поля параметров фрезерования →

→  →  → Введите координаты начальной точки ( X и Y) →  →

→ Начертите траекторию для операции фрезерования,

последовательно использую примитивы линия  и дуга  →
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→ Перейдите в основное меню фрезеровки  → 

Фрезерование текста

Insert → Millings → Basic → Text → Заполните поля параметров текста →  →

→ Insert → Millings → Basic → Milling from geometry → 

→ Заполните поля параметров фрезерования → 

Опустошение профиля

Insert → Millings → Basic → Define geometry → 

→ Заполните поля параметров геометрии →  →   → 

→ Введите координаты начальной точки ( X и Y) →  →

→ Начертите замкнутую траекторию, использую примитивы линия  и дуга  →

→ Перейдите в основное меню фрезеровки  →  →  →

→ Введите параметры опустошения профиля → 
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Опустошение профиля в форме текста

Insert → Millings → Basic → Text → Заполните поля параметров текста →  →

→  → Введите параметры опустошения профиля → 

Сверление отверстия

Insert → Bores → Generic bore → Заполните поля параметров сверления → 

Сверление системы отверстий

Insert → Bores → System bore → 

→ Заполните поля параметров сверления системы отверстий → 

Раскрой (выборка паза)

Insert → Cuts → Basic → Generic cut → Заполните поля параметров раскроя → 
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Пример программы обработки в окне EDITOR:

Вставка дополнительных функций
ISO code Insert → Functions → Basic → ISO code

Вставка инструкции в коде ISO
Move piece Insert → Functions → Basic → Move piece

Смещение начальной точки

Rotate geometry Insert → Functions → Basic → Rotate geometry
Повернуть геометрию

Geometry scale Insert → Functions → Basic → Geometry scale
Масштабирование геометрии

Move geometry Insert → Functions → Basic → Move geometry
Смещение геометрии

Wait for piece positioning Insert → Functions → Basic → Wait for piece positioning
Пауза в обработке

Sides from geometry Insert → Functions → Basic → Sides from geometry
Преобразование элемента чертежа в сторону детали
Insert → Functions → Basic → 
Insert → Functions → Basic → 
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Оптимизация программы обработки
После создания программы обработки необходимо провести оптимизацию, это необходимо для 
проверки правильности составленной программы.

Вид оптимизации можно выбрать в настройках: Settings → Optimiser → Optimisation type.
(Рекомендуемая – by time (по времени))

Нажмите левой кнопкой мыши на значке 

Информационное окно о результатах оптимизации появится только в том случае, если в 
программе обработки присутствуют ошибки.

Графическая симуляция программы обработки:
 Нажмите левой кнопкой мыши на значке  → 

При запуске симуляции программа обработки предварительно проходит оптимизацию. Если 
программа обработки содержит ошибки и не проходит оптимизацию, то симуляция не будет 
запущена.

Оснащение рабочего стола

Оснащение рабочего стола осуществляется в программе WORKTABLETOOLING:
Откройте окно Editor  → Tools → Table Tooling
→ 
Если в параметрах заготовки не были указаны упоры, программа предложит выбрать их
→ Расположите элементы рабочего стола

(элементы рабочего стола не попадали в зону обработки) →

→ Нажмите иконку  для применения внесенных изменений и возврата к окну Editor. 

Запуск программы обработки

Для записи программы в список исполнения (job list) нажмите последовательно иконки 

19



Для выполнения программы:
Нажмите на PLC клавиши Clear → Stop → Reset → Start 

Выполнение программ обработок используя программу BATCHRUN

Программы можно запускать по отдельности (через EDITOR) или использую рабочий список 
(BATCHRUN).

Запуск программы BATCHRUN:
Start → Programms → BiesseWorks → Tools → BatchRun

Порядок действий по созданию нового заказа и его исполнению:
 → Создание нового заказа  → 

→ В поле Machines выберите наименование применяемого станка →

→ В поле Subfolder введите имя папки в которую желаете сохранить файл →

→ Добавьте программы обработки в рабочий список  → 

Выполнение программ обработок используя WORKLIST

Откройте окно WORKLIST
Quote → Windows → WORKLIST →
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→ Откройте окно Editor →  
 → Поместите требуемые программы обработки в рабочий лист

(смотрите раздел «Запуск программы обработки») → 

 → Нажмите на PLC клавиши Clear → Stop → Reset → Start

Резервное копирование элементов программы BIESSEWORKS и их 
восстановление 

Резервное копирование данных:

Запустите программу BACKUP MANAGER:

Start → Programms → BiesseWorks → Tools → BackupManager

→ Выберите опцию Copy →  →  → Укажите путь и имя файла для сохранения →

→ Отметьте строчку Active machine →  → 

→ Укажите программы обработки которые необходимо сохранить →

→  → Перенесите макросы, которые необходимо сохранить в право → 

Восстановление данных из резервной копии:

Запустите программу BACKUP MANAGER:

Start → Programms → BiesseWorks → Tools → BackupManager

 Выберите опцию Restore →  →  Укажите путь и имя файла резервной копии →

→ Open →Выберите элементы, которые необходимо сохранить 
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→  → 

 

Работа с офисной версией BIESSEWORKS

– Создайте резервную копию данных станка (смотрите раздел выше);
– Установите программу BIESSEWORKS на офисном компьютере;
– Внедрите данные станка в офисную версию BIESSEWORKS 

(смотрите выше «Восстановление данных из резервной копии»);

После проделанных операций офисная версия BIESSEWORKS готова к работе.

Созданные программы в офисной версии BIESSEWORKS можно переносить в обрабатывающий 
центр для исполнения, используя мобильные носители информации (например flashdrive).

!!! Перед переносом программ в обрабатывающий центр убедитесь в отсутствии на 
носителе информации вредоносных программ (вирусов). 
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Необходимо дополнить:

Дополнительные функции в программе обработке

Описание окна оптимизатора при возникновении ошибок

Разделы 15.6 – 15.15

Использование переменных

Макросы

24


	1 Программное обеспечение обрабатывающих центров с ЧПУ
	2 WRT
	3 BIESSEWORKS
	Функциональные ограничения
	Уровень доступа пользователя
	Работа с базой инструментов
	Оснащение рабочих групп
	Получение дополнительной информации по оснащению станка

	Создание программ обработок
	Фрезерование по траектории
	Фрезерование текста
	Опустошение профиля
	Опустошение профиля в форме текста
	Сверление отверстия	
	Сверление системы отверстий
	Раскрой (выборка паза)
	Вставка дополнительных функций

	Оптимизация программы обработки
	Оснащение рабочего стола
	Запуск программы обработки
	Выполнение программ обработок используя программу BATCHRUN
	Выполнение программ обработок используя WORKLIST
	Резервное копирование элементов программы BIESSEWORKS и их восстановление 
	Работа с офисной версией BIESSEWORKS

	Оглавление

